Security Updates

Hello,

We are committed to providing a safe and reliable commerce experience for everyone. This includes making sure that when you access your account whether a guest or registered user, or proceeding through a checkout, all information and internet connections are kept private and secure.

For this reason, We will be halting support for the outdated security protocols TLS 1.0 and 1.1 on May 31, 2018. Our change coincides with new regulations set by the Payment Card Industry Data Security Standard (PCI), which will prohibit the use of TLS 1.0 as of June 30, 2018, and we're pro-actively ending support for TLS 1.1 in advance of any external requirements.

While this does not affect the majority of customers, a very small percentage may be impacted if browsers and operating systems are not updated. Please visit the SSL Labs SSL Test to check the highest version of TLS supported by your browser.

  • May 03, 2018
  • Category: News
  • Comments: 0
Leave a comment